(Bez tytułu)

Dostawca — karta

Karta Dostawca pozwala wybrać odpowiedniego dostawcę baz danych OLE dla typu danych, do których chcesz uzyskać dostęp. Nie wszystkie aplikacje pozwalają na określenie dostawcy lub modyfikację aktualnego wyboru; ta karta jest wyświetlana tylko wtedy, gdy aplikacja pozwala na edycję wyboru dostawcy baz danych OLE. Łącze danych można zapisać z aplikacją lub jako osobny plik. Więcej informacji na temat tworzenia łącza danych można znaleźć w temacie "Creating a Data Link" w zestawie MDAC SDK.

Opcja | Opis
Dostawcy OLE DB | Wyświetla wszystkich dostawców baz danych OLE wykrytych na dysku twardym. Więcej informacji na temat dostawców można znaleźć w temacie "Microsoft OLE DB Providers Overview" w zestawie MDAC SDK.
Dalej | Przechodzi do karty Połączenie wybranego dostawcy baz danych OLE.

Uwaga Do karty Połączenie można przejść bezpośrednio, klikając dwukrotnie żądanego dostawcę. Więcej informacji na temat łączy danych można znaleźć w dokumencie Data Link API Reference.


Zaawansowane — karta

Karta Zaawansowane służy do wyświetlania i ustawiania innych właściwości inicjujących dla danych.

Karta Zaawansowane okna dialogowego Właściwości łącza danych zależy od dostawcy i wyświetla tylko te właściwości inicjujące, które są wymagane przez wybranego dostawcę baz danych OLE. Więcej informacji na temat zaawansowanych właściwości inicjujących można znaleźć w dokumentacji każdego dostawcy baz danych OLE.

W następującej tabeli opisano większość opcji inicjujących.

Opcja | Opis
Poziom uosobienia Poziom uosobienia, jakiego może użyć serwer, gdy uosabia klienta. Właściwość ta stosowna jest tylko do połączeń sieciowych innych niż połączenia RPC; poziom uosobienia jest zbliżony do oferowanego przez zdalne wywołanie procedury (RPC, Remote Procedure Call). Wartości tej właściwości odpowiadają bezpośrednio poziomom uosobienia, które mogą być określone dla uwierzytelnionego połączenia RPC, ale mogą być stosowane dla połączeń innych niż uwierzytelnione połączenia RPC. Wybierz spośród następujących poziomów:
  • Anonymous — Klient jest anonimowy dla serwera. Proces serwera nie może uzyskać informacji identyfikujących klienta i nie może uosabiać klienta.

  • Delegate — Proces serwera może uosabiać kontekst zabezpieczeń klienta podczas występowania w imieniu klienta. Proces serwera może również realizować wywołania wychodzące do innych serwerów podczas występowania w imieniu klienta.

  • Identify — Serwer może uzyskać informacje identyfikujące klienta. Serwer może uosabiać klienta przy sprawdzaniu listy kontroli dostępu (ACL, Access Control List), ale nie może uzyskiwać dostępu do obiektów systemu jako klient.

  • Impersonate — Proces serwera może uosabiać kontekst zabezpieczeń klienta podczas występowania w imieniu klienta. Informacje te są uzyskiwane podczas ustanawiania połączenia, a nie przy każdym wywołaniu.
Poziom ochrony Poziom ochrony danych przesyłanych pomiędzy klientem i serwerem. Właściwość ta stosowna jest tylko do połączeń sieciowych innych niż połączenia RPC; poziom ochrony jest zbliżony do oferowanego przez zdalne wywołanie procedury (RPC, Remote Procedure Call). Wartości tej właściwości odpowiadają bezpośrednio poziomom ochrony które mogą być określone dla uwierzytelnionego połączenia RPC, ale mogą być stosowane dla połączeń innych niż uwierzytelnione połączenia RPC. Wybierz spośród następujących poziomów:
  • Call — Uwierzytelnianie źródła danych odbywa się na początku każdego żądania klienta w stosunku serwera.

  • Connect — Uwierzytelnianie odbywa się tylko podczas ustanawiania połączenia z serwerem przez klienta.

  • None — Dane przesyłane na serwer nie są uwierzytelniane.

  • Pkt — Podczas uwierzytelniania następuje sprawdzenie, czy wszystkie dane pochodzą od klienta.

  • Pkt Integrity — Podczas uwierzytelniania następuje sprawdzenie, czy wszystkie dane pochodzą od klienta i czy nie uległy one zmianie podczas przesyłania.

  • Pkt Privacy — Podczas uwierzytelniania następuje sprawdzenie, czy wszystkie dane pochodzą od klienta i czy nie uległy one zmianie podczas przesyłania, a ponadto chroniona jest prywatność danych przez ich zaszyfrowanie.
Limit czasu połączenia | Określa przedział czasu (w sekundach), przez który dostawca baz danych OLE oczekuje na zakończenie procesu inicjalizacji. Jeśli ten limit czasu zostanie przekroczony, zwracany jest kod błędu i połączenie nie jest tworzone.
Uprawnienia dostępu Wybierz jedno lub kilka następujących uprawnień:
  • Read — Tylko odczyt.

  • ReadWrite — Odczyt i zapis.

  • Share Deny None — Ani odczyt, ani zapis nie może być zabroniony innym użytkownikom.

  • Share Deny Read — Uniemożliwia innym użytkownikom otwieranie w trybie odczytu.

  • Share Deny Write — Uniemożliwia innym użytkownikom otwieranie w trybie zapisu.

  • Share Exclusive — Uniemożliwia innym użytkownikom otwieranie w trybie odczytu/zapisu.

  • Write — Tylko zapis.

Uwaga Więcej informacji na temat inicjalizacji łącza danych można znaleźć w dokumencie Data Link API Reference.


Wszystkie — karta

Użyj karty Wszystkie, aby wyświetlić lub poddać edycji wszystkie właściwości inicjujące bazy danych OLE dostępne dla dostawcy baz danych OLE. Właściwości te mogą się różnić w zależności od używanego dostawcy baz danych OLE. Więcej informacji na temat właściwości inicjujących można znaleźć w dokumentacji każdego dostawcy baz danych OLE.

Opcja | Opis
Lista właściwości inicjujących | Wyświetla wszystkie właściwość i ich bieżące wartości.
Edytuj wartość | Otwiera okno dialogowe Edytowanie wartości właściwości dla wybranej właściwości.

Uwaga Okno dialogowe Edytowanie wartości właściwości można również otworzyć klikając dwukrotnie żądaną właściwość. Więcej informacji na temat inicjalizacji łącza danych można znaleźć w dokumencie Data Link API Reference.


Połączenie — karta

Karta Połączenie pozwala określić, w jaki sposób łączyć się z danymi używając dostawcy baz danych OLE.

Karta Połączenie okna dialogowego Właściwości łącza danych zależy od dostawcy i wyświetla tylko te właściwości połączenia, które są wymagane przez wybranego dostawcę baz danych OLE. Właściwości połączenia pozwalają określić, gdzie znajdują się dane i jak się z nimi połączyć. Więcej informacji można znaleźć w dokumentacji każdego dostawcy baz danych OLE.

W następującej tabeli opisano większość opcji połączenia.

Opcja | Opis
Źródło danych | Wpisz nazwę źródła danych, do którego chcesz uzyskać dostęp. Zwykle jest to nazwa serwera.
Lokalizacja | Wpisz lokalizację źródła danych, do którego chcesz uzyskać dostęp. Zwykle jest to nazwa bazy danych.
Użyj wbudowanych zabezpieczeń systemu Windows NT | Kliknij, aby używać usługi uwierzytelniania do identyfikacji swojej osoby. Aby używać tej funkcji, dostawca baz danych OLE musi obsługiwać usługę uwierzytelniania. Przykładem jest dostawca Microsoft OLE DB dla programu SQL Server. Ponadto, w źródle danych musisz mieć uprawnienia do używania usługi uwierzytelniania.
Użyj określonej nazwy użytkownika i hasła | Kliknij, aby używać określonej nazwy użytkownika i hasła do uwierzytelnienia informacji logowania w źródle danych.
Nazwa użytkownika | Wpisz identyfikator użytkownika, który ma być używany do uwierzytelniania podczas logowania do źródła danych.
Hasło | Wpisz hasło, które ma być używane do uwierzytelniania podczas logowania do źródła danych.
Puste hasło | Umożliwia określonemu dostawcy zwracanie pustego hasła w ciągu połączenia.
Zezwalaj na zapisywanie hasła | Zezwala na zapisywanie hasła w ciągu połączenia. To, czy hasło zostanie dołączone do ciągu połączenia, zależy od funkcjonalności aplikacji wywołującej. Uwaga Zapisywane hasło jest zwracane i zapisywane jako nie zamaskowane i nie zaszyfrowane.
Wprowadź początkowy katalog do użycia | Wpisz nazwę katalogu, do którego chcesz mieć dostęp po połączeniu.
Testuj połączenie | Kliknij, aby wypróbować połączenie z określonym źródłem danych. Jeśli połączenie nie powiedzie się, upewnij się, czy ustawienia są poprawne. Przyczyną niepowodzenia może być na przykład błędna pisownia lub nieuwzględnienie rozróżniania wielkości znaków.

Uwaga Więcej informacji na temat połączeń łącza danych można znaleźć w dokumencie Data Link API Reference.


Połączenie — karta dla aparatu bazy danych Jet

Karta Połączenie pozwala określić, w jaki sposób łączyć się z danymi programu Microsoft Access.

Karta Połączenie zależy od dostawcy i wyświetla tylko te właściwości połączenia, które są wymagane przez dostawcę baz danych OLE dla aparatu bazy danych Microsoft Jet.

Opcja | Opis
Nazwa bazy danych | Wpisz nazwę pliku bazy danych Microsoft Access (.mdb), do którego chcesz uzyskać dostęp. Aby wyszukać plik, kliknij przycisk.
Nazwa użytkownika | Wpisz identyfikator użytkownika, który ma być używany do uwierzytelniania podczas logowania do źródła danych.
Hasło | Wpisz hasło, które ma być używane do uwierzytelniania podczas logowania do źródła danych.
Puste hasło | Umożliwia określonemu dostawcy zwracanie pustego hasła w ciągu połączenia.
Zezwalaj na zapisywanie hasła | Zezwala na zapisywanie hasła w ciągu połączenia. To, czy hasło zostanie dołączone do ciągu połączenia, zależy od funkcjonalności aplikacji wywołującej. Uwaga Zapisywane hasło jest zwracane i zapisywane jako nie zamaskowane i nie zaszyfrowane.
Testuj połączenie | Kliknij, aby wypróbować połączenie z określonym źródłem danych. Jeśli połączenie nie powiedzie się, upewnij się, czy ustawienia są poprawne. Przyczyną niepowodzenia może być na przykład błędna pisownia lub nieuwzględnienie rozróżniania wielkości znaków.

Uwaga Więcej informacji na temat połączeń łącza danych można znaleźć w dokumencie Data Link API Reference.


Połączenie — karta dla ODBC

Karta Połączenie pozwala określić, w jaki sposób łączyć się z danymi ODBC.

Karta Połączenie zależy od dostawcy i wyświetla tylko te właściwości połączenia, które są wymagane przez dostawcę Microsoft OLE DB dla ODBC.

Opcja | Opis
Użyj nazwy źródła danych | Wybierz z listy lub wpisz nazwę źródła danych ODBC (DSN), do którego chcesz uzyskać dostęp. Więcej źródeł możesz dodać korzystając z Administratora źródeł danych ODBC. Odśwież listę klikając przycisk Odśwież.
Użyj ciągu połączenia | Pozwala na wpisanie lub skonstruowanie ciągu połączenia ODBC zamiast używania istniejącej nazwy DSN.
Konstruuj Otwiera okno dialogowe Wybierania źródła danych. Jeśli wybierzesz źródło danych, ciąg połączenia w tym źródle danych pojawia się na karcie Połączenie okna dialogowego Właściwości łącza danych.

Jeśli wybierzesz opcję Plikowe DSN, wynikowy ciąg połączenia ODBC nie jest oparty na nazwie DSN. Ciąg połączenia ODBC jest umieszczany w pliku łącza danych (.udl) i nie zależy od wybranego plikowego DSN.

Jeśli wybierzesz opcję Komputerowe DSN, wynikowy ciąg połączenia ODBC jest oparty na nazwie DSN. Ciąg połączenia ODBC odwołuje się do wybranego komputerowego DSN. Jeśli użytkownik innego systemu próbuje uzyskać dostęp do pliku łącza danych (.udl), użytkownik ten musi mieć również zainstalowane komputerowe DSN.
Nazwa użytkownika | Wpisz identyfikator użytkownika, który ma być używany do uwierzytelniania podczas logowania do źródła danych.
Hasło | Wpisz hasło, które ma być używane do uwierzytelniania podczas logowania do źródła danych.
Puste hasło | Umożliwia określonemu dostawcy zwracanie pustego hasła w ciągu połączenia.
Zezwalaj na zapisywanie hasła Zezwala na zapisywanie hasła w ciągu połączenia. To, czy hasło zostanie dołączone do ciągu połączenia, zależy od funkcjonalności aplikacji wywołującej.

Uwaga Zapisywane hasło jest zwracane i zapisywane jako nie zamaskowane i nie zaszyfrowane.
Wprowadź początkowy katalog do użycia | Wpisz nazwę katalogu (lub bazy danych) albo wybierz ją z listy rozwijanej.
Testuj połączenie | Kliknij, aby wypróbować połączenie z określonym źródłem danych. Jeśli połączenie nie powiedzie się, upewnij się, czy ustawienia są poprawne. Przyczyną niepowodzenia może być na przykład błędna pisownia lub nieuwzględnienie rozróżniania wielkości znaków.

Uwaga Więcej informacji na temat połączeń łącza danych można znaleźć w dokumencie Data Link API Reference.


Połączenie — karta dla programu Oracle

Karta Połączenie pozwala określić, w jaki sposób łączyć się z danymi programu Oracle.

Karta Połączenie zależy od dostawcy i wyświetla tylko te właściwości połączenia, które są wymagane przez dostawcę Microsoft OLE DB dla programu Oracle.

Opcja | Opis
Nazwa serwera | Wpisz nazwę serwera zawierającego bazę danych, do której chcesz uzyskać dostęp.
Nazwa użytkownika | Wpisz identyfikator użytkownika, który ma być używany do uwierzytelniania podczas logowania do źródła danych.
Hasło | Wpisz hasło, które ma być używane do uwierzytelniania podczas logowania do źródła danych.
Puste hasło | Umożliwia określonemu dostawcy zwracanie pustego hasła w ciągu połączenia.
Zezwalaj na zapisywanie hasła | Zezwala na zapisywanie hasła w ciągu połączenia. To, czy hasło zostanie dołączone do ciągu połączenia, zależy od funkcjonalności aplikacji wywołującej. Uwaga Zapisywane hasło jest zwracane i zapisywane jako nie zamaskowane i nie zaszyfrowane.
Testuj połączenie | Kliknij, aby wypróbować połączenie z określonym źródłem danych. Jeśli połączenie nie powiedzie się, upewnij się, czy ustawienia są poprawne. Przyczyną niepowodzenia może być na przykład błędna pisownia lub nieuwzględnienie rozróżniania wielkości znaków.

Uwaga Więcej informacji na temat połączeń łącza danych można znaleźć w dokumencie Data Link API Reference.


Połączenie — karta dla programu SQL Server

Karta Połączenie pozwala określić, w jaki sposób łączyć się z danymi programu Microsoft SQL Server.

Karta Połączenie zależy od dostawcy i wyświetla tylko te właściwości połączenia, które są wymagane przez dostawcę Microsoft OLE DB dla programu Microsoft SQL Server.

Opcja | Opis
Nazwa serwera | Wybierz nazwę serwera z listy rozwijanej lub wpisz lokalizację serwera zawierającego bazę danych, do której chcesz uzyskać dostęp. Wybór bazy danych jest osobną czynnością. Odśwież listę klikając przycisk Odśwież.
Użyj wbudowanych zabezpieczeń systemu Windows NT | Kliknij, aby określić, że dostawca wymaga bezpiecznego (lub zaufanego) połączenia z serwerem SQL Server uruchamianym w systemie Microsoft Windows NT. Jeśli opcja ta zostanie wybrana, podczas ustanawiania połączenia z tym źródłem danych serwer SQL Server używa wbudowanych zabezpieczeń logowania, niezależnie od bieżącego trybu zabezpieczeń logowania na serwerze. Wszelkie podawane identyfikatory logowania i hasła są ignorowane. Administrator serwera SQL musi mieć identyfikator sieci Microsoft Windows skojarzony z identyfikatorem logowania serwera SQL Server.
Użyj określonej nazwy użytkownika i hasła | Kliknij, aby używać określonej nazwy użytkownika i hasła do uwierzytelnienia informacji logowania w źródle danych.
Nazwa użytkownika | Wpisz identyfikator użytkownika, który ma być używany do uwierzytelniania podczas logowania do źródła danych.
Hasło | Wpisz hasło, które ma być używane do uwierzytelniania podczas logowania do źródła danych.
Puste hasło | Umożliwia określonemu dostawcy zwracanie pustego hasła w ciągu połączenia.
Zezwalaj na zapisywanie hasła Zezwala na zapisywanie hasła w ciągu połączenia. To, czy hasło zostanie dołączone do ciągu połączenia, zależy od funkcjonalności aplikacji wywołującej.

Uwaga Zapisywane hasło jest zwracane i zapisywane jako nie zamaskowane i nie zaszyfrowane.
Wybierz bazę danych Użyj jednej z następujących metod:
  • Wpisz nazwę bazy, do której chcesz uzyskać dostęp.

  • Dla serwera SQL Server 7.0, dołącz plik bazy danych SQL jako nazwę bazy danych. Wpisz nazwę bazy danych, która ma być używana dla dołączonego pliku bazy danych SQL.

  • Dla serwera SQL Server w wersji 6.5 lub starszej, wpisz nazwę pliku bazy danych, który ma zostać dołączony. Następnie wpisz nazwę pojedynczego pliku bazy danych. Aby wyszukać plik, kliknij przycisk.
Testuj połączenie | Kliknij, aby wypróbować połączenie z określonym źródłem danych. Jeśli połączenie nie powiedzie się, upewnij się, czy ustawienia są poprawne. Przyczyną niepowodzenia może być na przykład błędna pisownia lub nieuwzględnienie rozróżniania wielkości znaków.

Uwaga Więcej informacji na temat połączeń łącza danych można znaleźć w dokumencie Data Link API Reference.


Data Link API Reference

Więcej informacji na temat interfejsu API łącza danych można znaleźć na stronie sieci Web msdn.microsoft.com. (Otwórz witrynę MSDN Library Online, a następnie stronę Platform SDK, aby znaleźć zestaw MDAC SDK, który zawiera dokument Data Link API Reference.)


Edytowanie wartości właściwości — okno dialogowe

Okno dialogowe Edytowanie wartości właściwości służy do edycji właściwości inicjującej bazy danych OLE aktualnie zaznaczonej na karcie Wszystkie. Właściwości mogą się różnić, w zależności od używanego dostawcy baz danych OLE.

Uwaga Więcej informacji na właściwości specyficznych dla dostawcy, można znaleźć w dokumentacji dostarczanej z każdym dostawcą baz danych OLE.

Opcja | Opis
Opis właściwości | Wyświetla opis wybranej właściwości.
Wartość właściwości | Wybierz poprawną wartość.
Resetuj wartość | Ustawia wartość wybranej właściwości na domyślną wartość dostawcy baz danych OLE .